aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMatias Linares <matiaslina@openmailbox.org>2015-11-19 21:11:34 -0300
committerMatias Linares <matiaslina@openmailbox.org>2015-11-19 21:11:34 -0300
commita21473f60c6cfad6335db3b0b45cdff23f8b3a89 (patch)
treeb5e37b1cd9d2146c5930c75aca84c74a9fbcc57d /Cargo.toml
parent27d0eddd4c1cc275d90938c350a3563428ec5b4f (diff)
downloaddotwm-a21473f60c6cfad6335db3b0b45cdff23f8b3a89.tar.gz
Implemented socket handler.
First steps on the socket handling. Dotwm will use this for communication between different clients trying to modify the behaviour (just take a look into hlwm's herbstclient program). It's needed a parser for the configuration, make the protocol and get it working better. For now I'm checking if it's anything into the socket every time I've a XEvent. But it shouldn't be this way.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a83691d..66e2b19 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -5,6 +5,7 @@ authors = ["Matias Linares <matiaslina@openmailbox.org>"]
[dependencies]
libc = "0.2.*"
+unix_socket = "*"
[dependencies.x11]
version = "*"